Hello Guest, if you are reading this it means you have not registered yet. Please take a second, Click here to register, and in a few simple steps you will be able to enjoy our community and use our OpenViX support section.
Page 45 of 45 FirstFirst ... 35434445
Results 661 to 667 of 667

Thread: Build my own Vix image

  1. #661

    Title
    ViX Beta Tester
    Join Date
    May 2011
    Posts
    681
    Thanks
    56
    Thanked 236 Times in 163 Posts
    Getting a new error today whilst compiling the rtl8852cu part due to an argument list being too long. Attached is the compile log (hope it's the right log).

    Not sweating it right now in case it gets corrected in the next few days.
    Attached Files Attached Files

  2. #662
    birdman's Avatar
    Title
    Moderator
    Join Date
    Sep 2014
    Location
    Hitchin, UK
    Posts
    7,775
    Thanks
    236
    Thanked 1,656 Times in 1,305 Posts
    Quote Originally Posted by lincsat View Post
    Getting a new error today whilst compiling the rtl8852cu part due to an argument list being too long. Attached is the compile log (hope it's the right log).

    Not sweating it right now in case it gets corrected in the next few days.
    A workaround would be to run the build from a place with a shorter pathname, since that is copied multiple times into each command line.

    Bind-mount the build-environment somewhere (I put mine under /var/tmp/dev-build). Although the pathname change may (will?) mean you need to redo everything from scratch.
    MiracleBox Prem Twin HD - 2@DVB-T2 + Xtrend et8000 - 5(incl. 2 different USBs)@DVB-T2[terrestrial - UK Freeview HD, Sandy Heath] - LAN/USB-stick/HDD

  3. #663

    Title
    ViX Beta Tester
    Join Date
    May 2011
    Posts
    681
    Thanks
    56
    Thanked 236 Times in 163 Posts
    Quote Originally Posted by birdman View Post
    A workaround would be to run the build from a place with a shorter pathname, since that is copied multiple times into each command line.

    Bind-mount the build-environment somewhere (I put mine under /var/tmp/dev-build). Although the pathname change may (will?) mean you need to redo everything from scratch.
    Not familiar with that, so would I create the mount like this
    Code:
    mount --bind /media/lincsat/imagebuilder/openvixbuilder/build-enviroment /var/tmp/dev-build
    Then
    Code:
    cd /var/tmp/dev-build
    and run all the commands including make update and make image from there

  4. #664
    birdman's Avatar
    Title
    Moderator
    Join Date
    Sep 2014
    Location
    Hitchin, UK
    Posts
    7,775
    Thanks
    236
    Thanked 1,656 Times in 1,305 Posts
    Quote Originally Posted by lincsat View Post
    Not familiar with that, so would I create the mount like this
    Code:
    mount --bind /media/lincsat/imagebuilder/openvixbuilder/build-enviroment /var/tmp/dev-build
    Then
    Code:
    cd /var/tmp/dev-build
    and run all the commands including make update and make image from there
    Yes. (Or you can use mount -o bind ....they seem to be the same).
    MiracleBox Prem Twin HD - 2@DVB-T2 + Xtrend et8000 - 5(incl. 2 different USBs)@DVB-T2[terrestrial - UK Freeview HD, Sandy Heath] - LAN/USB-stick/HDD

  5. The Following User Says Thank You to birdman For This Useful Post:

    lincsat (05-02-24)

  6. #665

    Title
    Forum Supporter
    Donated Member
    Join Date
    Oct 2022
    Location
    Berkshire England. 51.4N, 0.9W
    Posts
    79
    Thanks
    107
    Thanked 24 Times in 17 Posts
    Quote Originally Posted by lincsat View Post
    The svn.streamboard.tv site has been offline for a few days causing builds to fail at the initial stage. Is there an easy way to disable the streamboard/oscam check temporally until the site is back online, maybe with a recipes-local file?
    It's down again.

    The five *.bbappend files discussed here a couple of pages back still seem to work, at least to allow building, but I haven't tested the resulting oscams it builds.
    Zgemma H7S, Fixed 28.2E dish, Freeview (Hannington). ABM Providers: [Sky UK; Thames Valley SD Custom; HD swap], [Freeview (UK); Berks and North Hants]

  7. #666

    Title
    ViX Beta Tester
    Join Date
    May 2011
    Posts
    681
    Thanks
    56
    Thanked 236 Times in 163 Posts
    Quote Originally Posted by BrianG61UK View Post
    It's down again.

    The five *.bbappend files discussed here a couple of pages back still seem to work, at least to allow building, but I haven't tested the resulting oscams it builds.
    I've just built a 6.5.3.003 Dev image for a Zgemma H9SE without needing the files, so I guess streamboard is back online.

  8. The Following User Says Thank You to lincsat For This Useful Post:

    BrianG61UK (03-04-24)

  9. #667
    abu baniaz's Avatar
    Title
    Moderator
    Join Date
    Sep 2010
    Location
    East London
    Posts
    23,357
    Thanks
    6,438
    Thanked 9,160 Times in 6,235 Posts
    The oscam bitbake files have changed to use Hains repository. Those append files are not required and may actually cause an issue now.

  10. The Following User Says Thank You to abu baniaz For This Useful Post:

    BrianG61UK (05-04-24)

Page 45 of 45 FirstFirst ... 35434445

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.