Hello Guest, if you are reading this it means you have not registered yet. Please take a second, Click here to register, and in a few simple steps you will be able to enjoy our community and use our OpenViX support section.
Results 1 to 9 of 9

Thread: Samba not starting on OpenVIX - 6.2.006

  1. #1

    Title
    Senior Member
    Join Date
    Aug 2013
    Posts
    228
    Thanks
    1
    Thanked 6 Times in 6 Posts

    Samba not starting on OpenVIX - 6.2.006

    Hello,

    Just upgraded to OpenVIX - 6.2.006 and restored settings, but Samba wont start.

    I have removed the Samba service and added it back, but it still wont start.

    Any ideas?

    Thanks

  2. #2
    Huevos's Avatar
    Title
    Administrator
    Join Date
    Jun 2010
    Location
    38.5N, 0.5W
    Posts
    12,120
    Thanks
    1,927
    Thanked 4,272 Times in 2,828 Posts
    Probably using an old config file.

    Current ones are here: https://github.com/oe-alliance/oe-al...ty/samba/samba

  3. #3

    Title
    Senior Member
    Join Date
    Aug 2013
    Posts
    228
    Thanks
    1
    Thanked 6 Times in 6 Posts
    Hello,

    Thanks for your response.

    Do I simply copy "oe-alliance-core/meta-oe/recipes-connectivity/samba/samba/openvix/smb-branding.conf" to the /etc/samba/distro/ folder?

    Thanks
    Last edited by msuk; 13-07-22 at 17:10.

  4. #4

    Title
    Senior Member
    Join Date
    Aug 2013
    Posts
    228
    Thanks
    1
    Thanked 6 Times in 6 Posts
    Hi,

    Copied smb-branding.conf" to the /etc/samba/distro/ folder and Samba now starts.

    Also copied users.map to /etc/samba/private

    When trying to access from my Windows 11 PC the share is asking for user credentials, which I am providing, but wont show any files. Says Access Denied.

    Thanks
    Last edited by msuk; 13-07-22 at 18:17.

  5. #5

    Title
    Forum Supporter
    Donated Member
    Join Date
    Jun 2010
    Posts
    2,605
    Thanks
    1,072
    Thanked 362 Times in 332 Posts
    Does pc need the password you setup on box to gain entry on it?

  6. #6

    Title
    Senior Member
    Join Date
    Aug 2013
    Posts
    228
    Thanks
    1
    Thanked 6 Times in 6 Posts
    Hello, Yes, the share needs the box credentials i.e. root/password to gain access to the hard drive.

  7. #7
    adm's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2014
    Location
    Southend on Sea, UK
    Posts
    1,414
    Thanks
    49
    Thanked 529 Times in 410 Posts
    Quote Originally Posted by msuk View Post
    Hello, Yes, the share needs the box credentials i.e. root/password to gain access to the hard drive.
    Does you PC actually recognise your box and then just fail to display the contents of its hard disk?

    I had problems recently with the PC saying wrong credentials for my box when trying to see it via SAMBA. I went to my box and entered a new password which was the same as the one I'd previously set up. My PC still refused to recognise my box UNTIL I had rebooted my box twice.
    Xtrend ET10K, 2 x satellite tuners 28.2 (Sky FTA), 2 x hybrid (UK Freeview), Zgemma H9S (satellite)

  8. #8

    Title
    Senior Member
    Join Date
    Aug 2013
    Posts
    228
    Thanks
    1
    Thanked 6 Times in 6 Posts
    Hello,

    Does you PC actually recognise your box and then just fail to display the contents of its hard disk? - Yes and I have rebooted the box several times but same problem. The folders are shown in Windows, I enter root/password, explorer refreshes but no files are actually shown. Then credentials Window pops up again.

    Thanks

  9. #9

    Title
    Senior Member
    Join Date
    Aug 2013
    Posts
    228
    Thanks
    1
    Thanked 6 Times in 6 Posts
    Hi again,

    Powered the box off, waited 30secs and powered it back on. The share is now working.

    Thanks

  10. The Following User Says Thank You to msuk For This Useful Post:

    Huevos (15-07-22)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.