Hello Guest, if you are reading this it means you have not registered yet. Please take a second, Click here to register, and in a few simple steps you will be able to enjoy our community and use our OpenViX support section.

View Entry Info: Online Upgrade Crash (log attached)

Category:
Possible Bug
What ViX Image build number are you using?
Please provide your ViX Team image build number. Menu > Information > About > Build number > ENTER THIS NUMBER e.g. 4.2.028
6.6.006
Have you tried a flash WITHOUT settings restore?
Have you tried this? PLEASE SELECT YES OR NO.
Yes
Have you tried a flash WITH settings restore?
Have you tried this? PLEASE SELECT YES OR NO.
Yes
Attachments
Page 1 of 4 123 ... LastLast
Results 1 to 15 of 48

Thread: Online Upgrade Crash (log attached)

  1. #1

    Title
    Senior Member
    Join Date
    Nov 2011
    Posts
    179
    Thanks
    12
    Thanked 11 Times in 11 Posts

    Online Upgrade Crash (log attached)

    OK, been having various problems lately, mainly a very slow boot (around 3 minutes). Tried various things, factory reset, upgrade from 5 > 6.
    Now getting a lot of crashes, so tried to do an online flash (tried latest V6 and a downgrade to V5) but the box just crashes when I click "flash" (blue button).
    Any help appreciated.

    Log attached.

    Regards,
    Spoooo


    Code:
    <  3995.1333> 10:03:13.1299 [InfoBarGenerics] Key: 352 (Make) KeyID='KEY_OK' Binding='('OK',)'.
    <  3995.1334> 10:03:13.1300 [ActionMap] Keymap 'OkCancelActions' -> Action = 'ok'.
    <  3995.1355> 10:03:13.1321 Traceback (most recent call last):
    <  3995.1355> 10:03:13.1322   File "/usr/lib/enigma2/python/Components/ActionMap.py", line 60, in action
    <  3995.1361> 10:03:13.1327     res = self.actions[action]()
    <  3995.1361> 10:03:13.1328   File "/usr/lib/enigma2/python/Plugins/SystemPlugins/ViX/ImageManager.py", line 403, in keyRestore
    <  3995.1368> 10:03:13.1335     imagedict = GetImagelist()
    <  3995.1369> 10:03:13.1335   File "/usr/lib/enigma2/python/Tools/Multiboot.py", line 135, in GetImagelist
    <  3995.1376> 10:03:13.1343     Creator = BoxInfo.getItem("distro").title()
    <  3995.1378> 10:03:13.1344 AttributeError: 'NoneType' object has no attribute 'title'
    <  3995.1379> 10:03:13.1345 [ePyObject] (CallObject(<bound method ActionMap.action of <Components.ActionMap.ActionMap object at 0xb0a9c988>>,('OkCancelActions', 'ok')) failed)
    Last edited by abu baniaz; 08-01-22 at 11:28. Reason: Add log snippet

  2. #2
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    7,082
    Thanks
    864
    Thanked 2,504 Times in 1,914 Posts
    OK, I need to look at that issue …… will be tomorrow probably
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  3. The Following User Says Thank You to twol For This Useful Post:

    Sicilian (12-01-22)

  4. #3
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    7,082
    Thanks
    864
    Thanked 2,504 Times in 1,914 Posts
    So copy the attachment into /usr/lib/enigma2/python/Tools and reboot.
    Preferably in putty init 4 (space between)
    Copy and then
    init 6 (using putty)
    Attached Files Attached Files
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  5. The Following User Says Thank You to twol For This Useful Post:

    Sicilian (12-01-22)

  6. #4

    Title
    Senior Member
    Join Date
    Nov 2011
    Posts
    179
    Thanks
    12
    Thanked 11 Times in 11 Posts
    Hi.
    Thanks for your swift attention.
    I tired the new file but unfortunately, the box still crashes when I click "flash".

  7. #5
    Huevos's Avatar
    Title
    Moderator
    Join Date
    Jun 2010
    Location
    38.5N, 0.5W
    Posts
    11,198
    Thanks
    1,862
    Thanked 4,059 Times in 2,679 Posts
    That is the idea. Please post debug/crash log from the crash.

    The file posted was not a fix. It was an attempt to get more debug data.

  8. #6
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    7,082
    Thanks
    864
    Thanked 2,504 Times in 1,914 Posts
    Quote Originally Posted by Spoof View Post
    Hi.
    Thanks for your swift attention.
    I tired the new file but unfortunately, the box still crashes when I click "flash".
    updated module to hopefully give me some info and allow you to flash. Instructions as before.....

    After you have hopefully flashed, I need last 2 debug logs(current and last log from previous image)
    Attached Files Attached Files
    Last edited by twol; 09-01-22 at 12:54.
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  9. #7

    Title
    Senior Member
    Join Date
    Nov 2011
    Posts
    179
    Thanks
    12
    Thanked 11 Times in 11 Posts
    OK, log attached.
    The image flashed ok with the new multiboot.py, so no crash log!

    Many thanks!

  10. #8
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    7,082
    Thanks
    864
    Thanked 2,504 Times in 1,914 Posts
    Quote Originally Posted by Spoof View Post
    OK, log attached.
    The image flashed ok with the new multiboot.py, so no crash log!

    Many thanks!
    Sorry, meant can I have the the current and last debug logs........!!

    Also what/whose images did you have in the slots???? .... looks like you had a corrupted file in the flashed image
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  11. #9

    Title
    Senior Member
    Join Date
    Nov 2011
    Posts
    179
    Thanks
    12
    Thanked 11 Times in 11 Posts
    I had Vix 6.0.006 in slot 1 and flashed back to 5.4.016 (other slots empty).
    I didn't have debug log enabled.

  12. #10

    Title
    Senior Member
    Join Date
    Nov 2011
    Posts
    179
    Thanks
    12
    Thanked 11 Times in 11 Posts
    As a further update, downgrading back to 5.4 cured the slow boot (around 3 minutes in v6) and so far no random crashes either.
    Not sure whether this is related to the multiboot.py file.

  13. #11
    Huevos's Avatar
    Title
    Moderator
    Join Date
    Jun 2010
    Location
    38.5N, 0.5W
    Posts
    11,198
    Thanks
    1,862
    Thanked 4,059 Times in 2,679 Posts
    Quote Originally Posted by Spoof View Post
    As a further update, downgrading back to 5.4 cured the slow boot (around 3 minutes in v6) and so far no random crashes either.
    Not sure whether this is related to the multiboot.py file.
    Never heard of a 3 minute boot on a modern box. You must have something configured wrong.

  14. #12

    Title
    Senior Member
    Join Date
    Nov 2011
    Posts
    179
    Thanks
    12
    Thanked 11 Times in 11 Posts
    Quote Originally Posted by Huevos View Post
    Never heard of a 3 minute boot on a modern box. You must have something configured wrong.
    It coincided with the upgrade form v5 > v6 (same setting). Now back on 5.4.016 and it boots fine (didn't time it but much less than a minute).
    Will retry v6 when I get time and report back.

  15. #13
    Joe_90's Avatar
    Title
    Moderator
    Join Date
    Mar 2014
    Location
    Wicklow, Ireland
    Posts
    3,387
    Thanks
    1,081
    Thanked 931 Times in 736 Posts
    My mutant hd51 boots from cold into displaying channel in 40-ish seconds on a Release 6 Vix image. It's about 5 seconds slower than Release 5. You must be doing something different with the version 6 image. Turn on debug log and reboot.
    GB Quad Plus, Mut@nt HD51, AX HD61, 80cm dish and Supreme Dark motor. Sony STR-DN 1060, Sony UHP-H1 Bluray, Odroid N2+ (CoreElec), Monitor Audio Bronze 5.1 speakers

  16. The Following User Says Thank You to Joe_90 For This Useful Post:

    Huevos (11-01-22)

  17. #14

    Title
    Senior Member
    Join Date
    Nov 2011
    Posts
    179
    Thanks
    12
    Thanked 11 Times in 11 Posts
    Some further testing and enclosed logs.
    Log name with image version and boot time.

  18. #15
    birdman's Avatar
    Title
    Moderator
    Join Date
    Sep 2014
    Location
    Hitchin, UK
    Posts
    6,954
    Thanks
    201
    Thanked 1,539 Times in 1,202 Posts
    The v5 one start up enigma2 ~14s after the system boots whereas the v6 one doesn't start it until 106s in.

    So the problem is before enigma2 itself starts.

    The v6 one also seems to be part of Multiboot, whereas the v5 one isn't.
    Last edited by birdman; 11-01-22 at 18:38.
    MiracleBox Prem Twin HD - 2@DVB-T2 + Xtrend et8000 - 5(incl. 2 different USBs)@DVB-T2[terrestrial - UK Freeview HD, Sandy Heath] - LAN/USB-stick/HDD

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.