Hello Guest, if you are reading this it means you have not registered yet. Please take a second, Click here to register, and in a few simple steps you will be able to enjoy our community and use our OpenViX support section.

View Entry Info: Softcam Screen Crash

Category:
Possible Bug
What ViX Image build number are you using?
Please provide your ViX Team image build number. Menu > Information > About > Build number > ENTER THIS NUMBER e.g. 4.2.028
5.4.015
Have you tried a flash WITHOUT settings restore?
Have you tried this? PLEASE SELECT YES OR NO.
No
Have you tried a flash WITH settings restore?
Have you tried this? PLEASE SELECT YES OR NO.
No
Attachments
Results 1 to 7 of 7

Thread: Softcam Screen Crash

  1. #1

    Title
    Junior Member
    Join Date
    May 2013
    Posts
    12
    Thanks
    7
    Thanked 3 Times in 3 Posts

    Softcam Screen Crash

    Hi all mates,


    I flashed and factory settings to my duo4k and Unfortunately, Softcam screen crashing
    I attached log file.

    Meanwhile; This image is slower than older images.My machine,channel speed and others was faster before

    Have a good sunday to all
    Attached Files Attached Files

  2. #2
    ccs's Avatar
    Title
    ViX Beta Tester
    Join Date
    Sep 2014
    Posts
    4,901
    Thanks
    497
    Thanked 1,152 Times in 982 Posts
    Same/similar to crash reported here...

    https://www.world-of-satellite.com/s...l=1#post517515

    Code:
    <    63.0740> 11:02:09.8114 [eRCDeviceInputDev] emit: 1
    <    63.0745> 11:02:09.8119 [InfoBarGenerics] Key: 352 (Make) KeyID='KEY_OK' Binding='('OK',)'.
    <    63.0746> 11:02:09.8120 [ActionMap] Keymap 'WizardActions' -> Action = 'ok'.
    <    63.0754> 11:02:09.8128 [Screen] Showing screen 'InfoBarSummary'.
    <    63.0923> 11:02:09.8297 [Skin] Parsing embedded skin '<embedded-in-VIXSoftcamManager>'.
    <    63.0929> 11:02:09.8303 [Skin] Processing screen '<embedded-in-VIXSoftcamManager>', position=(680, 340), size=(560 x 400) for module 'VIXSoftcamManager'.
    <    63.1013> 11:02:09.8387 [gAccel] alloc failed
    <    63.1013> 11:02:09.8387 [gSurface] ERROR: accelAlloc failed
    <    63.1023> 11:02:09.8397 [gAccel] alloc failed
    <    63.1023> 11:02:09.8397 [gSurface] ERROR: accelAlloc failed
    <    63.1089> 11:02:09.8463 [Skin] Processing screen 'SimpleSummary' from list 'VIXSoftcamManagerSummary, ScreenSummary, VIXSoftcamManager_summary, SimpleSummary', position=(0, 0), size=(480 x 320) for module 'PluginBrowserSummary'.
    <    63.1159> 11:02:09.8534 [Screen] Showing screen '['VIXSoftcamManagerSummary', 'ScreenSummary', 'VIXSoftcamManager_summary', 'SimpleSummary']'.
    <    63.1161> 11:02:09.8535 [SoftcamManager] Selectedcam: oscam-latest
    <    63.1350> 11:02:09.8724 [Screen] Showing screen 'VIXSoftcamManager'.
    <    63.1377> 11:02:09.8751 [Console] command: ps.procps -C oscam-latest | grep -v 'CMD' | sed 's/</ /g' | awk '{print $4}' | awk '{a[$1] = $0} END { for (x in a) { print a[x] } }'
    <    63.1378> 11:02:09.8753 [eConsoleAppContainer] Starting /bin/sh
    <    63.1566> 11:02:09.8940 [Console] finished: ps.procps -C oscam-latest | grep -v 'CMD' | sed 's/</ /g' | awk '{print $4}' | awk '{a[$1] = $0} END { for (x in a) { print a[x] } }'
    <    63.1569> 11:02:09.8943 Traceback (most recent call last):
    <    63.1569> 11:02:09.8943   File "/usr/lib/enigma2/python/Components/Console.py", line 48, in finishedCB
    <    63.1571> 11:02:09.8945   File "/usr/lib/enigma2/python/Plugins/SystemPlugins/ViX/SoftcamManager.py", line 232, in showActivecam2
    <    63.1572> 11:02:09.8946   File "/usr/lib/enigma2/python/Components/config.py", line 2022, in __getattr__
    <    63.1573> 11:02:09.8947 AttributeError: softcams
    <    63.1575> 11:02:09.8949 [ePyObject] (CallObject(<bound method EnigmaLogFatal.write of <bound method ConsoleItem.dataAvailCB of <bound method EnigmaLogDebug.write of <bound method ConditionalShowHide.__getattr__ of <bound method Progress.changed of <bound method Progress.changed of <bound method CList.__call__ of <bound method eSlider.eSlider_setValue of <bound method eLabel.eLabel_setText of <bound method Converter.changed of <bound method ClockToText.changed of <bound method CList.__call__ of <bound method Label.changed of <bound method Label.changed of <bound method CList.__call__ of <bound method eLabel.eLabel_setText of <bound method CList.__call__ of <bound method eSlider.eSlider_setValue of <bound method eLabel.eLabel_setText of <bound method PliExtraInfo.changed of <bound method PliExtraInfo.changed of <bound method PliExtraInfo.changed of <bound method PliExtraInfo.changed of <bound method CryptoInfo.changed of <bound method PliExtraInfo.changed of <bound method ServicePosition.changed of <bound method ServicePosition.changed of <bound method ServicePosition.changed of <bound method ChannelNumber.changed of <bound method CList.__call__ of <bound method Converter.changed of <bound method Label.changed of <bound method CList.__call__ of <bound method eLabel.eLabel_setText of <bound method Pixmap.changed of <bound method CList.__call__ of <bound method ConditionalShowHide.__getattr__ of <unbound method ConditionalShowHide.__getattr__>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>,(0,)) failed)
    Last edited by ccs; 03-10-21 at 11:22.

  3. #3

    Title
    Forum Supporter
    Donated Member
    Join Date
    Jan 2016
    Location
    Sweden
    Posts
    75
    Thanks
    72
    Thanked 8 Times in 6 Posts
    Hi all!

    And thanks to you all for the development and improvement of OpenVix!

    Same here, did a fresh install (Duo 4K 5.4.015) and restored settings and plugins from 5.4.013

    Got one crash and reboot, after reboot and the box seemed to be stable I did made many channel changes and measured the times,
    it took about 4 - 6 seconds before the picture came, the sound came around a second before the picture.
    It was a little faster to go back to the previous channel, but longer again to an unused channel.

    I tried another skin, with the same result. I use oscam, No card sharing. Tried some previous versions of oscam, but the same results with all of them.

    I went back to 5.4.013, I would be happy to try again with 5.4.015 if I can be of help with something for you experts that can hopefully solve this problem.

    Unfortunately I did not save any logs from 5.4.015 but I would be happy to install 5.4.015 again if it can be helpful for surveys.
    Vu+ Duo 4K 1 x FBC S2(X) on 0.8 W, 4 TB HD 2.5"
    Vu+ Ultimo 4K 1 x FBC S2(X) on 0.8 W, 2 TB HD 2.5"
    All with latest stable image
    80 cm dish with Diavolo Unicable II LNB

  4. #4
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    6,826
    Thanks
    851
    Thanked 2,420 Times in 1,852 Posts
    Softcam error is down to some py3 code … I will fix it tomorrow.
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  5. The Following 3 Users Say Thank You to twol For This Useful Post:

    Clabs (03-10-21),kamaxx (03-10-21),Toja60 (03-10-21)

  6. #5

    Title
    Member
    Join Date
    Mar 2012
    Posts
    70
    Thanks
    22
    Thanked 2 Times in 2 Posts

    Box Crashing OSCAM

    Hi, I have just flashed with clean image, everything is ok apart from Enigma2_crash_2021-10-08_18-21-46.logOSCAM, getting box crashing, Enigma2_crash_2021-10-08_18-21-46.log

    Logs Attached

  7. #6
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    6,826
    Thanks
    851
    Thanked 2,420 Times in 1,852 Posts
    Quote Originally Posted by spevs View Post
    Hi, I have just flashed with clean image, everything is ok apart from Enigma2_crash_2021-10-08_18-21-46.logOSCAM, getting box crashing, Enigma2_crash_2021-10-08_18-21-46.log

    Logs Attached
    See post #3 here https://www.world-of-satellite.com/s...-manager-crash
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  8. The Following User Says Thank You to twol For This Useful Post:

    spevs (09-10-21)

  9. #7

    Title
    Member
    Join Date
    Mar 2012
    Posts
    70
    Thanks
    22
    Thanked 2 Times in 2 Posts
    Thanks, all sorted.......

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.