Hello Guest, if you are reading this it means you have not registered yet. Please take a second, Click here to register, and in a few simple steps you will be able to enjoy our community and use our OpenViX support section.

View Entry Info: FAV screen sorting broken

Category:
Possible Bug
What ViX Image build number are you using?
Please provide your ViX Team image build number. Menu > Information > About > Build number > ENTER THIS NUMBER e.g. 4.2.028
5.4.013 and 5.5.013.016 (Py3) and probably many earlier versions
Have you tried a flash WITHOUT settings restore?
Have you tried this? PLEASE SELECT YES OR NO.
No
Have you tried a flash WITH settings restore?
Have you tried this? PLEASE SELECT YES OR NO.
No
Attachments
Results 1 to 15 of 15

Thread: FAV screen sorting broken

  1. #1
    BefuddledBrian's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2020
    Location
    near Reading, England
    Posts
    417
    Thanks
    300
    Thanked 54 Times in 45 Posts

    FAV screen sorting broken

    This is the screen of bouquet's that comes up if I press the [FAV] button on my remote:
    FAV.jpg

    If I try to change the order by pressing [MENU] [RED] to go into move mode it gets mangled and I can never get the order back to normal.
    Even just exiting from move mode changes the order again!
    I have to restore backed up settings to get back to normal.

    (I actually only tried this accidentally first because I had forgotten to exit move mode after sorting the contents of my extras bouquet)
    Last edited by BefuddledBrian; 02-07-21 at 15:20.

  2. #2
    adm's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2014
    Location
    Southend on Sea, UK
    Posts
    1,223
    Thanks
    43
    Thanked 462 Times in 362 Posts
    Quote Originally Posted by BefuddledBrian View Post
    This is the screen of bouquet's that comes up if I press the [FAV] button on my remote:
    FAV.jpg

    If I try to change the order by pressing [MENU] [RED] to go into move mode it gets mangled and I can never get the order back to normal.
    Even just exiting from move mode changes the order again!
    I have to restore backed up settings to get back to normal.

    (I actually only tried this accidentally first because I had forgotten to exit move mode after sorting the contents of my extras bouquet)
    Although not a solution for the on-screen mode but I find that using the webif and bouquet editor much simpler.
    Xtrend ET10K, 2 x satellite tuners 28.2 (Sky FTA), 2 x hybrid (UK Freeview), Zgemma H9S (satellite)

  3. #3
    ccs's Avatar
    Title
    ViX Beta Tester
    Join Date
    Sep 2014
    Posts
    4,651
    Thanks
    467
    Thanked 1,097 Times in 933 Posts
    ... me too, I've never got the gui to work.

  4. #4
    BefuddledBrian's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2020
    Location
    near Reading, England
    Posts
    417
    Thanks
    300
    Thanked 54 Times in 45 Posts
    Quote Originally Posted by ccs View Post
    ... me too, I've never got the gui to work.
    It works fine for copying entries into and then reordering them in my Extras Bouquet (aka favourites, not made by ABM), but it permanantly makes things weird if activated on the bouquet names themselves.

  5. #5
    BefuddledBrian's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2020
    Location
    near Reading, England
    Posts
    417
    Thanks
    300
    Thanked 54 Times in 45 Posts
    Quote Originally Posted by BefuddledBrian View Post
    This is the screen of bouquet's that comes up if I press the [FAV] button on my remote:
    FAV.jpg
    Would you say the way I have my bouquets set up is unusual and/or not how it was intended to be used?
    (Just using the all-channels bouquets and no subset bouquets, favourites bouquet renamed to Extras, I can zap to a sky channel with its official Sky number or to a Freeview channel with 2000+its official number)
    Last edited by BefuddledBrian; 02-07-21 at 22:08.

  6. #6
    BefuddledBrian's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2020
    Location
    near Reading, England
    Posts
    417
    Thanks
    300
    Thanked 54 Times in 45 Posts
    Why no more comments on this?
    Does nobody care that this is totally screwed up?
    And now I discover that after one screws things up like this then restoring settings to get back to sanity is screwed up too.

  7. #7
    Huevos's Avatar
    Title
    Moderator
    Join Date
    Jun 2010
    Location
    38.5N, 0.5W
    Posts
    10,283
    Thanks
    1,792
    Thanked 3,785 Times in 2,494 Posts
    Build and version number please?

  8. #8

    Title
    ViX Beta Tester
    Join Date
    Apr 2011
    Location
    Ireland
    Posts
    1,801
    Thanks
    375
    Thanked 593 Times in 482 Posts
    I've just checked and indeed it is broken. If you move a bouquet down the list it will jump back when you disable move mode. If you move a bouquet up a place it jumps up another place when disabling move mode. On 5.5.014.001
    Last edited by ronand; 11-07-21 at 18:36.
    Zgemma H7S running OpenVIX 5.4, Darkmotor, Triax TD110 dish, Inverto Black Ultra dual lnb
    LG 50UM7450 4K TV, Pioneer VSX-534 AVR , LG UBK80 4K Bluray & a Playstation 4.

  9. #9

    Title
    ViX Beta Tester
    Join Date
    Apr 2011
    Location
    Ireland
    Posts
    1,801
    Thanks
    375
    Thanked 593 Times in 482 Posts
    If you want to move a bouquet down one you must move it down 2 spaces and then exit. Then it jumps back up one.
    Zgemma H7S running OpenVIX 5.4, Darkmotor, Triax TD110 dish, Inverto Black Ultra dual lnb
    LG 50UM7450 4K TV, Pioneer VSX-534 AVR , LG UBK80 4K Bluray & a Playstation 4.

  10. The Following User Says Thank You to ronand For This Useful Post:

    BefuddledBrian (12-07-21)

  11. #10
    Huevos's Avatar
    Title
    Moderator
    Join Date
    Jun 2010
    Location
    38.5N, 0.5W
    Posts
    10,283
    Thanks
    1,792
    Thanked 3,785 Times in 2,494 Posts
    I can't reproduce this. Maybe there is another setting in the mix.

  12. #11
    ccs's Avatar
    Title
    ViX Beta Tester
    Join Date
    Sep 2014
    Posts
    4,651
    Thanks
    467
    Thanked 1,097 Times in 933 Posts
    Quote Originally Posted by Huevos View Post
    I can't reproduce this. Maybe there is another setting in the mix.
    I managed to move a bouquet, but when I exited, the box rebooted, no crash log or any clue why.

    That was on 5.4.013 (Release).

  13. #12
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    6,661
    Thanks
    833
    Thanked 2,345 Times in 1,794 Posts
    Quote Originally Posted by ronand View Post
    I've just checked and indeed it is broken. If you move a bouquet down the list it will jump back when you disable move mode. If you move a bouquet up a place it jumps up another place when disabling move mode. On 5.5.014.001
    Interesting its working for me, but I don‘t have FAV button so I have to use the up button/blue button/menu to get there.
    If anybody could post debug would like to see it so I can check against my debug
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  14. #13
    Huevos's Avatar
    Title
    Moderator
    Join Date
    Jun 2010
    Location
    38.5N, 0.5W
    Posts
    10,283
    Thanks
    1,792
    Thanked 3,785 Times in 2,494 Posts
    Quote Originally Posted by twol View Post
    Interesting its working for me, but I don‘t have FAV button so I have to use the up button/blue button/menu to get there.
    If anybody could post debug would like to see it so I can check against my debug
    Haven't you got a Mio? Anyway does the same as pressing "tv" button, or same as pressing blue from ChannelSelection.

    No clue about the crash... doesn't happen to me.
    Last edited by Huevos; 14-07-21 at 07:32.

  15. #14
    BefuddledBrian's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2020
    Location
    near Reading, England
    Posts
    417
    Thanks
    300
    Thanked 54 Times in 45 Posts

    Lightbulb

    Here is debug log: Enigma2_debug_2021-07-12_16-19-17.zip (at least I hope it's the right one).
    Bouquet's were set up as in image in that thread.
    As soon as I came out of move mode the bouquet order was changed.
    It would help me to not accidentally do this if it was not possible to accidentally leave yourself in move mode after moving channels around within a bouquet.

    (This is a repost from: https://www.world-of-satellite.com/s...l=1#post515576)

    Maybe the problem only occurs with the very simple bouquet arraingement I use with just a main bouquet for each provider.
    Last edited by BefuddledBrian; 16-07-21 at 02:40.

  16. #15

    Title
    Senior Member
    Join Date
    Jun 2015
    Posts
    294
    Thanks
    55
    Thanked 50 Times in 43 Posts
    Quote Originally Posted by BefuddledBrian View Post
    Here is debug log: Enigma2_debug_2021-07-12_16-19-17.zip (at least I hope it's the right one).
    Bouquet's were set up as in image in that thread.
    As soon as I came out of move mode the bouquet order was changed.
    It would help me to not accidentally do this if it was not possible to accidentally leave yourself in move mode after moving channels around within a bouquet.

    (This is a repost from: https://www.world-of-satellite.com/s...l=1#post515576)

    Maybe the problem only occurs with the very simple bouquet arraingement I use with just a main bouquet for each provider.
    Good point about the move mode. Maybe it would be better if when exiting the menus the box could ask if you want to exit move mode?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.