Hello Guest, if you are reading this it means you have not registered yet. Please take a second, Click here to register, and in a few simple steps you will be able to enjoy our community and use our OpenViX support section.

View Entry Info: opentvzapper plugin causing autotimer to crash

Category:
Possible Bug
What ViX Image build number are you using?
Please provide your ViX Team image build number. Menu > Information > About > Build number > ENTER THIS NUMBER e.g. 4.2.028
5.4.005
Have you tried a flash WITHOUT settings restore?
Have you tried this? PLEASE SELECT YES OR NO.
No
Have you tried a flash WITH settings restore?
Have you tried this? PLEASE SELECT YES OR NO.
No
Attachments
Page 1 of 2 12 LastLast
Results 1 to 15 of 25

Thread: opentvzapper plugin causing autotimer to crash

  1. #1

    Title
    ViX Beta Tester
    Join Date
    Apr 2011
    Location
    Ireland
    Posts
    1,535
    Thanks
    327
    Thanked 523 Times in 420 Posts

    opentvzapper plugin causing autotimer to crash

    I tried the new opentvzapper plugin which is supposed to replace epgrefresh but autotimer crashes sometimes when it is polled. Removing the plugin and restarting e2 solves it. I reinstalled it and the crashes returned.

    Debug log attached

    Enigma2_debug_2021-01-26_17-02-45.log
    Zgemma H7S running OpenVIX 5.4, Darkmotor, Triax TD110 dish, Inverto Black Ultra dual lnb
    LG 50UM7450 4K TV, Pioneer VSX-534 AVR , LG UBK80 4K Bluray & a Playstation 4.

  2. #2

    Title
    Forum Supporter
    Donated Member
    Join Date
    Jun 2014
    Posts
    1,240
    Thanks
    564
    Thanked 401 Times in 254 Posts
    Do you have crash log also?

  3. #3
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    6,281
    Thanks
    796
    Thanked 2,208 Times in 1,682 Posts
    Quote Originally Posted by ronand View Post
    I tried the new opentvzapper plugin which is supposed to replace epgrefresh but autotimer crashes sometimes when it is polled. Removing the plugin and restarting e2 solves it. I reinstalled it and the crashes returned.

    Debug log attached

    Enigma2_debug_2021-01-26_17-02-45.log
    Its the autotimer vps error (not opentvzapper).................... AutoTimerComponent' object has no attribute 'vpsplugin_overwrite'
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  4. #4

    Title
    ViX Beta Tester
    Join Date
    Apr 2011
    Location
    Ireland
    Posts
    1,535
    Thanks
    327
    Thanked 523 Times in 420 Posts
    Quote Originally Posted by twol View Post
    Its the autotimer vps error (not opentvzapper).................... AutoTimerComponent' object has no attribute 'vpsplugin_overwrite'
    Its only happening when the opentvzapper is installed. I dont use any vps plugin
    Zgemma H7S running OpenVIX 5.4, Darkmotor, Triax TD110 dish, Inverto Black Ultra dual lnb
    LG 50UM7450 4K TV, Pioneer VSX-534 AVR , LG UBK80 4K Bluray & a Playstation 4.

  5. #5

    Title
    ViX Beta Tester
    Join Date
    Sep 2014
    Posts
    3,973
    Thanks
    389
    Thanked 984 Times in 837 Posts
    There are recent commits to autotimer to check for the vps plugin....

    Code:
    https://github.com/oe-alliance/enigma2-plugins/commits/master
    Edit: I've just added the latest version of Autotimer.py to 5.4.005 without issues, although I'm not using opentvzapper .
    Last edited by ccs; 26-01-21 at 19:40.

  6. #6

    Title
    Forum Supporter
    Donated Member
    Join Date
    Jun 2014
    Posts
    1,240
    Thanks
    564
    Thanked 401 Times in 254 Posts
    I have 5.4.005 and I'm using OpenTVZapper without issue so far but don't have/use vps plugin

  7. #7

    Title
    ViX Beta Tester
    Join Date
    Apr 2011
    Location
    Ireland
    Posts
    1,535
    Thanks
    327
    Thanked 523 Times in 420 Posts
    I don't use the vps plugin (never have done) so I dont know why I have this issue. Its not a problem for me - just uninstalled opentvzapper and back to epg refresh and all is good.
    Zgemma H7S running OpenVIX 5.4, Darkmotor, Triax TD110 dish, Inverto Black Ultra dual lnb
    LG 50UM7450 4K TV, Pioneer VSX-534 AVR , LG UBK80 4K Bluray & a Playstation 4.

  8. #8

    Title
    ViX Beta Tester
    Join Date
    Sep 2014
    Posts
    3,973
    Thanks
    389
    Thanked 984 Times in 837 Posts
    One of the commits is labelled "[AutoTimer.py] Protect against BSoD when no vps plugin is present".

  9. #9
    birdman's Avatar
    Title
    Moderator
    Join Date
    Sep 2014
    Location
    Hitchin, UK
    Posts
    6,124
    Thanks
    170
    Thanked 1,420 Times in 1,102 Posts
    Quote Originally Posted by twol View Post
    Its the autotimer vps error (not opentvzapper).................... AutoTimerComponent' object has no attribute 'vpsplugin_overwrite'
    Fixed yesterday.
    I think this only happened when AutoTimer actually added a new timer, hence it is likely to occur just after the EPG gets updated (something now matches).
    MiracleBox Prem Twin HD - 2@DVB-T2 + Xtrend et8000 - 5(incl. 2 different USBs)@DVB-T2[terrestrial - UK Freeview HD, Sandy Heath] - LAN/USB-stick/HDD

  10. The Following 2 Users Say Thank You to birdman For This Useful Post:

    bbbuk (26-01-21),ronand (27-01-21)

  11. #10
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    6,281
    Thanks
    796
    Thanked 2,208 Times in 1,682 Posts
    Quote Originally Posted by ronand View Post
    I don't use the vps plugin (never have done) so I dont know why I have this issue. Its not a problem for me - just uninstalled opentvzapper and back to epg refresh and all is good.
    Thats why you and I have the issue! But its not opentvzapper!
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  12. #11

    Title
    Forum Supporter
    Donated Member
    Join Date
    Jun 2014
    Posts
    1,240
    Thanks
    564
    Thanked 401 Times in 254 Posts

    Post

    Quote Originally Posted by birdman View Post
    Fixed yesterday.
    I think this only happened when AutoTimer actually added a new timer, hence it is likely to occur just after the EPG gets updated (something now matches).
    Explains why I haven't yet noticed this crash because I've not yet had reason to add new AutoTimer.



    Edit: For anyone wanting it until next release of Vix 5.4.006, see post 14 for latest file
    Last edited by abu baniaz; 28-01-21 at 02:57. Reason: Removed AutoTimer

  13. The Following User Says Thank You to bbbuk For This Useful Post:

    ronand (27-01-21)

  14. #12

    Title
    ViX Beta Tester
    Join Date
    Sep 2014
    Posts
    3,973
    Thanks
    389
    Thanked 984 Times in 837 Posts
    ... I think it's more to do with autotimer adding a new timer rather than adding a new autotimer.

  15. The Following 2 Users Say Thank You to ccs For This Useful Post:

    bbbuk (26-01-21),ronand (27-01-21)

  16. #13
    adm's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2014
    Location
    Southend on Sea, UK
    Posts
    1,157
    Thanks
    39
    Thanked 430 Times in 341 Posts
    Quote Originally Posted by ccs View Post
    ... I think it's more to do with autotimer adding a new timer rather than adding a new autotimer.
    For most people it's probably the same thing. Add an autotimer and save and few minutes later it searches the EPG to set timers.

    Could there be a problem if autotimers and opentvzapper are polling/operating at exactly the same time in the background?
    Last edited by adm; 26-01-21 at 22:49.
    Xtrend ET10K, 2 x satellite tuners 28.2 (Sky FTA), 2 x hybrid (UK Freeview), Zgemma H9S (satellite)

  17. #14

    Title
    ViX Beta Tester
    Join Date
    Sep 2014
    Posts
    3,973
    Thanks
    389
    Thanked 984 Times in 837 Posts
    Quote Originally Posted by bbbuk View Post
    Edit: Added latest AutoTimer not tested it personally yet though.

    Added file below for anyone wanting it until next release of Vix 5.4.006

    Rename existing AutoTimer.pyo file in /usr/lib/enigma2/python/Plugins/Extensions/AutoTimer to say AutoTimer.xxx
    Transfer attached file to /usr/lib/enigma2/python/Plugins/Extensions/AutoTimer
    Shouldn't that be the .py file, aren't .pyo files architecture dependant?

    In case they are......

    Instructions:
    Rename existing AutoTimer.pyo file in /usr/lib/enigma2/python/Plugins/Extensions/AutoTimer to say AutoTimer.orig
    Transfer attached file to /usr/lib/enigma2/python/Plugins/Extensions/AutoTimer
    Perform a GUI restart
    A new .pyo file will then be created
    Delete the .py file you had transferred, otherwise future software updates could be compromised.
    Attached Files Attached Files
    Last edited by abu baniaz; 28-01-21 at 02:52. Reason: Instrcuctions

  18. The Following 3 Users Say Thank You to ccs For This Useful Post:

    abu baniaz (27-01-21),capistrano (04-02-21),ronand (27-01-21)

  19. #15

    Title
    ViX Beta Tester
    Join Date
    Apr 2011
    Location
    Ireland
    Posts
    1,535
    Thanks
    327
    Thanked 523 Times in 420 Posts
    That seems to have fixed the problem - thanks guys. However I will probably stick to using epgrefresh as I use it for Saorview as well.
    Zgemma H7S running OpenVIX 5.4, Darkmotor, Triax TD110 dish, Inverto Black Ultra dual lnb
    LG 50UM7450 4K TV, Pioneer VSX-534 AVR , LG UBK80 4K Bluray & a Playstation 4.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.