View Entry Info: 5.3.025 Crash in Image manage when downloading.

Category:
Possible Bug
What ViX Image build number are you using?
Please provide your ViX Team image build number. Menu > Information > About > Build number > ENTER THIS NUMBER e.g. 4.2.028
5.3.025
Have you tried a flash WITHOUT settings restore?
Have you tried this? PLEASE SELECT YES OR NO.
No
Have you tried a flash WITH settings restore?
Have you tried this? PLEASE SELECT YES OR NO.
No
Attachments
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: 5.3.025 Crash in Image manage when downloading.

  1. #1

    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2014
    Posts
    3,104
    Thanks
    289
    Thanked 759 Times in 645 Posts

    5.3.025 Crash in Image manage when downloading.

    Trying to download 5.3.026 using image manager on 5.3.025 (VU+ Ultimo 4K)

    Crashes every time when I select OpenViX from the download url.

    (ET10K ok when running 5.3.022)
    Attached Files Attached Files

  2. The Following 2 Users Say Thank You to ccs For This Useful Post:

    abu baniaz (25-04-20),Sicilian (30-04-20)

  3. #2
    Willo3092's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Oct 2016
    Location
    East Midlands
    Posts
    390
    Thanks
    392
    Thanked 200 Times in 138 Posts
    Same for me. It's fixed in 5.3.026.
    I flashed using putty with Grog68's script.

    wget --no-check-certificate -O install_vix.sh https://www.dropbox.com/s/hc2cdr116l...ll_vix.sh?dl=1 && bash install_vix.sh

  4. The Following 2 Users Say Thank You to Willo3092 For This Useful Post:

    ccs (25-04-20),Sicilian (30-04-20)

  5. #3
    abu baniaz's Avatar
    Title
    Moderator
    Join Date
    Sep 2010
    Location
    East London
    Posts
    20,668
    Thanks
    5,466
    Thanked 8,134 Times in 5,469 Posts
    The only real difference betwen 5.3 025 and 5.3 026 is to fix that crash. Most people will be happy updating to 026 instead of flashing so not a major issue. For those who prefer not to update and flash and restore, they will have to install python lxml to avoid the crash. Those on 5.3 026 or 5.3 024 and lower will not be affected

    opkg install python-lxml

    Or download and transfer zipped image. Grog's script won't create a settings backup, so not a good idea for this issue, IMO.

  6. The Following User Says Thank You to abu baniaz For This Useful Post:

    ccs (25-04-20)

  7. #4
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    5,887
    Thanks
    770
    Thanked 2,047 Times in 1,562 Posts
    Sorry guys - my fault on OE-A 4.4 there is apparently a version change that is not supported on OE-A 4.3 - hence the issue
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  8. #5

    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2014
    Posts
    3,104
    Thanks
    289
    Thanked 759 Times in 645 Posts
    Quote Originally Posted by abu baniaz View Post

    Or download and transfer zipped image.
    That's how I got 5.3.026 up an running.

  9. #6
    bellejt's Avatar
    Title
    Senior Member
    Join Date
    Dec 2013
    Posts
    1,427
    Thanks
    38
    Thanked 258 Times in 220 Posts
    just updated from 2.3.023 to 026 online and no problems on duo2.Had to do the special version on my octagon SF8008.
    VU+ DUO2 quad tuner with HDD 1 TB + Latest Openvix and VU+ DUO2 FB tuner + Octagon SF8008 FB tuner
    Triax 88 cm rotor single LNB 30 E- 40 W
    1 Gibertini 1.00 m fixed - 3 quad LNB 19E-23.5E-28.2E

  10. The Following 2 Users Say Thank You to bellejt For This Useful Post:

    abu baniaz (26-04-20),Sicilian (30-04-20)

  11. #7

    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2014
    Posts
    3,104
    Thanks
    289
    Thanked 759 Times in 645 Posts
    Bit off the original topic, but I've just had a crash in image manager (5.3.034), I couldn't telnet or openwebif to the box, but it said samba was running, so I tried an image download....

    Code:
    <   628.1540> 14:23:41.1724 [ActionMap] Keymap 'OkCancelActions' -> Action = 'ok'.
    <   628.1731> 14:23:41.1915 [Skin] Processing screen 'VIXMenu', position=(0, 0), size=(1920 x 1080) for module 'VIXMenu'.
    <   628.1847> 14:23:41.2031 [Skin] Processing screen 'PluginBrowserSummary', position=(0, 0), size=(800 x 480) for module 'PluginBrowserSummary'.
    <   628.4901> 14:23:41.5085 [eInputDeviceInit] 0 160 (352) 1
    <   628.4904> 14:23:41.5088 [InfoBarGenerics] KEY: 352 OK
    <   629.4541> 14:23:42.4725 [eInputDeviceInit] 1 6c (108) 1
    <   629.4544> 14:23:42.4728 [InfoBarGenerics] KEY: 108 DOWN
    <   629.4545> 14:23:42.4730 [ActionMap] Keymap 'WizardActions' -> Unknown action 'down'! (Typo in keymap?)
    <   629.7900> 14:23:42.8084 [eInputDeviceInit] 0 6c (108) 1
    <   629.7904> 14:23:42.8088 [InfoBarGenerics] KEY: 108 DOWN
    <   630.7164> 14:23:43.7348 [eInputDeviceInit] 1 160 (352) 1
    <   630.7166> 14:23:43.7351 [InfoBarGenerics] KEY: 352 OK
    <   630.7168> 14:23:43.7352 [ActionMap] Keymap 'WizardActions' -> Action = 'ok'.
    <   630.7294> 14:23:43.7479 [Skin] Processing screen 'VIXImageManager', position=(0, 0), size=(1920 x 1080) for module 'VIXImageManager'.
    <   630.7396> 14:23:43.7580 [GUISkin] warning, skin is missing element backupstatus in <class 'Plugins.SystemPlugins.ViX.ImageManager.VIXImageManager'>
    <   630.7427> 14:23:43.7612 [Skin] Processing screen 'SimpleSummary' from list 'VIXImageManager_summary, SimpleSummary', position=(0, 0), size=(800 x 480) for module 'SimpleSummary'.
    <   631.0532> 14:23:44.0716 [eInputDeviceInit] 0 160 (352) 1
    <   631.0535> 14:23:44.0719 [InfoBarGenerics] KEY: 352 OK
    <   633.5265> 14:23:46.5449 [eInputDeviceInit] 1 190 (400) 1
    <   633.5268> 14:23:46.5452 [InfoBarGenerics] KEY: 400 YELLOW
    <   633.9690> 14:23:46.9874 [eInputDeviceInit] 0 190 (400) 1
    <   633.9693> 14:23:46.9877 [InfoBarGenerics] KEY: 400 YELLOW
    <   633.9694> 14:23:46.9878 [ActionMap] Keymap 'ColorActions' -> Action = 'yellow'.
    <   633.9736> 14:23:46.9921 [Skin] Processing screen 'MessageBoxSimple', position=(480, 532), size=(960 x 15) for module 'MessageBox'.
    <   633.9822> 14:23:47.0006 [GUISkin] warning, skin is missing element icon in <class 'Screens.MessageBox.MessageBox'>(Do you want to change download url)
    <   633.9823> 14:23:47.0008 [Pixmap] setPixmapNum(0) failed! defined pixmaps: []
    <   633.9841> 14:23:47.0025 [Skin] Processing screen 'MessageBoxSimple_summary' from list 'MessageBoxSimple_summary, SimpleSummary', position=(0, 0), size=(800 x 480) for module 'SimpleSummary'.
    <   637.2877> 14:23:50.3062 [eInputDeviceInit] 1 160 (352) 1
    <   637.2881> 14:23:50.3066 [InfoBarGenerics] KEY: 352 OK
    <   637.2883> 14:23:50.3067 [ActionMap] Keymap 'MsgBoxActions' -> Action = 'ok'.
    <   637.3507> 14:23:50.3692 [ActionMap] Keymap(s) 'OkCancelActions, ColorActions, DirectionActions, KeyboardInputActions, MenuActions' -> Undefined action(s) 'downRepeated, upRepeated, rightRepeated, leftRepeated'.
    <   640.0126> 14:23:53.0310 [gRC] main thread is non-idle! display spinner!
    <   640.4013> 14:23:53.4197 Traceback (most recent call last):
    <   640.4013> 14:23:53.4197   File "/usr/lib/enigma2/python/mytest.py", line 244, in processDelay
    <   640.4015> 14:23:53.4199     callback(*retval)
    <   640.4016> 14:23:53.4200   File "/usr/lib/enigma2/python/Plugins/SystemPlugins/ViX/ImageManager.py", line 272, in doDownload2
    <   640.4018> 14:23:53.4202   File "/usr/lib/enigma2/python/mytest.py", line 329, in openWithCallback
    <   640.4020> 14:23:53.4204     dlg = self.open(screen, *arguments, **kwargs)
    <   640.4020> 14:23:53.4205   File "/usr/lib/enigma2/python/mytest.py", line 339, in open
    <   640.4023> 14:23:53.4207     dlg = self.current_dialog = self.instantiateDialog(screen, *arguments, **kwargs)
    <   640.4023> 14:23:53.4207   File "/usr/lib/enigma2/python/mytest.py", line 276, in instantiateDialog
    <   640.4025> 14:23:53.4209     return self.doInstantiateDialog(screen, arguments, kwargs, self.desktop)
    <   640.4025> 14:23:53.4209   File "/usr/lib/enigma2/python/mytest.py", line 299, in doInstantiateDialog
    <   640.4027> 14:23:53.4211     dlg = screen(self, *arguments, **kwargs)
    <   640.4027> 14:23:53.4211   File "/usr/lib/enigma2/python/Plugins/SystemPlugins/ViX/ImageManager.py", line 1346, in __init__
    <   640.4028> 14:23:53.4212   File "/usr/lib/enigma2/python/Plugins/SystemPlugins/ViX/ImageManager.py", line 1386, in getImageDistro
    <   640.4029> 14:23:53.4213   File "/usr/lib/python2.7/urllib2.py", line 155, in urlopen
    <   640.4030> 14:23:53.4214   File "/usr/lib/python2.7/urllib2.py", line 430, in open
    <   640.4031> 14:23:53.4215   File "/usr/lib/python2.7/urllib2.py", line 448, in _open
    <   640.4032> 14:23:53.4216   File "/usr/lib/python2.7/urllib2.py", line 408, in _call_chain
    <   640.4033> 14:23:53.4217   File "/usr/lib/python2.7/urllib2.py", line 1229, in http_open
    <   640.4034> 14:23:53.4218   File "/usr/lib/python2.7/urllib2.py", line 1199, in do_open
    <   640.4035> 14:23:53.4219 urllib2.URLError: <urlopen error [Errno -2] Name or service not known>
    <   640.4036> 14:23:53.4220 [ePyObject] (CallObject(<bound method Session.processDelay of <__main__.Session instance at 0x9e84e8c8>>,()) failed)
    Rebooted and everything ok.

  12. #8
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    5,887
    Thanks
    770
    Thanked 2,047 Times in 1,562 Posts
    1. is it repeatable?
    2. should have been caught by the Try/Except code - don‘t know why not

    I guess that the url was not available at the time —— can you try again and post result.
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  13. #9

    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2014
    Posts
    3,104
    Thanks
    289
    Thanked 759 Times in 645 Posts
    I doubt I can repeat it, I couldn't see the box via telnet, so I checked samba which was running, and then an image download as I was expecting the 35 release.

    I should have checked the networking side more thoroughly, but never expected a crash.

    It worked ok 2 minutes later, after a full reboot.
    Last edited by ccs; 22-06-20 at 17:27.

  14. The Following User Says Thank You to ccs For This Useful Post:

    twol (22-06-20)

  15. #10

    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2014
    Posts
    3,104
    Thanks
    289
    Thanked 759 Times in 645 Posts
    Wireless network "not connected" again tonight, restarted ok. Will debug logs provide more details?

    I didn't try to force a crash because of recordings.
    Last edited by ccs; 23-06-20 at 19:03.

  16. #11

    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2014
    Posts
    3,104
    Thanks
    289
    Thanked 759 Times in 645 Posts
    Quote Originally Posted by twol View Post
    1. is it repeatable?
    2. should have been caught by the Try/Except code - don‘t know why not

    I guess that the url was not available at the time —— can you try again and post result.
    Yes, all I need to do is disable the wireless lan.

    Trouble is, when I re-enable it, all the settings are lost, I'm sure that never happened on my ET10K.

    Logs will take a while longer. Ended up being quicker doing a settings restore!

    Not much different to previous crash log....

    Code:
       164.1687> 19:22:25.1087 [InfoBarGenerics] KEY: 400 YELLOW
    <   164.5041> 19:22:25.4442 [eInputDeviceInit] 0 190 (400) 1
    <   164.5047> 19:22:25.4447 [InfoBarGenerics] KEY: 400 YELLOW
    <   164.5049> 19:22:25.4449 [ActionMap] Keymap 'ColorActions' -> Action = 'yellow'.
    <   164.5083> 19:22:25.4483 [Skin] Processing screen 'MessageBoxSimple', position=(480, 532), size=(960 x 15) for module 'MessageBox'.
    <   164.5143> 19:22:25.4543 [GUISkin] warning, skin is missing element icon in <class 'Screens.MessageBox.MessageBox'>(Do you want to change download url)
    <   164.5144> 19:22:25.4544 [Pixmap] setPixmapNum(0) failed! defined pixmaps: []
    <   164.5161> 19:22:25.4561 [Skin] Processing screen 'MessageBoxSimple_summary' from list 'MessageBoxSimple_summary, SimpleSummary', position=(0, 0), size=(800 x 480) for module 'SimpleSummary'.
    <   168.3603> 19:22:29.3004 [eInputDeviceInit] 1 160 (352) 1
    <   168.3608> 19:22:29.3008 [InfoBarGenerics] KEY: 352 OK
    <   168.3610> 19:22:29.3011 [ActionMap] Keymap 'MsgBoxActions' -> Action = 'ok'.
    <   168.4169> 19:22:29.3569 [ActionMap] Keymap(s) 'OkCancelActions, ColorActions, DirectionActions, KeyboardInputActions, MenuActions' -> Undefined action(s) 'downRepeated, upRepeated, rightRepeated, leftRepeated'.
    <   170.5572> 19:22:31.4973 [gRC] main thread is non-idle! display spinner!
    [MAIN] executing main
    NXPL_RegisterNexusDisplayPlatform data->hwInterface 0xb3903a40
    TuxTxt cache cleared
    <   171.4651> 19:22:32.4052 Traceback (most recent call last):
    <   171.4652> 19:22:32.4052   File "/usr/lib/enigma2/python/mytest.py", line 244, in processDelay
    <   171.4654> 19:22:32.4054     callback(*retval)
    <   171.4655> 19:22:32.4055   File "/usr/lib/enigma2/python/Plugins/SystemPlugins/ViX/ImageManager.py", line 272, in doDownload2
    <   171.4657> 19:22:32.4057   File "/usr/lib/enigma2/python/mytest.py", line 329, in openWithCallback
    <   171.4659> 19:22:32.4060     dlg = self.open(screen, *arguments, **kwargs)
    <   171.4660> 19:22:32.4060   File "/usr/lib/enigma2/python/mytest.py", line 339, in open
    <   171.4663> 19:22:32.4063     dlg = self.current_dialog = self.instantiateDialog(screen, *arguments, **kwargs)
    <   171.4663> 19:22:32.4063   File "/usr/lib/enigma2/python/mytest.py", line 276, in instantiateDialog
    <   171.4665> 19:22:32.4065     return self.doInstantiateDialog(screen, arguments, kwargs, self.desktop)
    <   171.4666> 19:22:32.4066   File "/usr/lib/enigma2/python/mytest.py", line 299, in doInstantiateDialog
    <   171.4668> 19:22:32.4068     dlg = screen(self, *arguments, **kwargs)
    <   171.4668> 19:22:32.4068   File "/usr/lib/enigma2/python/Plugins/SystemPlugins/ViX/ImageManager.py", line 1346, in __init__
    <   171.4669> 19:22:32.4069   File "/usr/lib/enigma2/python/Plugins/SystemPlugins/ViX/ImageManager.py", line 1386, in getImageDistro
    <   171.4670> 19:22:32.4070   File "/usr/lib/python2.7/urllib2.py", line 155, in urlopen
    <   171.4672> 19:22:32.4072   File "/usr/lib/python2.7/urllib2.py", line 430, in open
    <   171.4673> 19:22:32.4073   File "/usr/lib/python2.7/urllib2.py", line 448, in _open
    <   171.4674> 19:22:32.4074   File "/usr/lib/python2.7/urllib2.py", line 408, in _call_chain
    <   171.4675> 19:22:32.4075   File "/usr/lib/python2.7/urllib2.py", line 1229, in http_open
    <   171.4676> 19:22:32.4076   File "/usr/lib/python2.7/urllib2.py", line 1199, in do_open
    <   171.4677> 19:22:32.4078 urllib2.URLError: <urlopen error [Errno -2] Name or service not known>
    <   171.4678> 19:22:32.4078 [ePyObject] (CallObject(<bound method Session.processDelay of <__main__.Session instance at 0x9e835e18>>,()) failed)
    <   173.5606> 19:22:34.5006 [gRC] main thread is non-idle! display spinner!
    Last edited by ccs; 23-06-20 at 19:52.

  17. The Following User Says Thank You to ccs For This Useful Post:

    bbbuk (28-06-20)

  18. #12
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    5,887
    Thanks
    770
    Thanked 2,047 Times in 1,562 Posts
    Its crashing because there is no network - it shouldn‘t because there is code to trap but obviously needs tweaking - will fix as soon as I have more time (currently recovering from knee op)
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  19. The Following 2 Users Say Thank You to twol For This Useful Post:

    bbbuk (28-06-20),ccs (24-06-20)

  20. #13

    Title
    Forum Supporter
    Donated Member
    Join Date
    Jun 2014
    Posts
    1,188
    Thanks
    526
    Thanked 387 Times in 245 Posts
    Ok, found away to handle this crash gracefully - see my suggested commit here.

    • doDownload() - added quick internet access check before allowing user to even try and choose an image to download. Displays error if no internet connection
    • getImageDistro() - corrects existing check that didn't correctly catch error if specific distro website is down (or no internet access)

    Tested several times, with and without internet access.
    Last edited by bbbuk; 28-06-20 at 12:04.

  21. The Following 4 Users Say Thank You to bbbuk For This Useful Post:

    Andy_Hazza (28-06-20),ccs (28-06-20),twol (28-06-20),Willo3092 (28-06-20)

  22. #14

    Title
    Forum Supporter
    Donated Member
    Join Date
    Sep 2014
    Posts
    3,104
    Thanks
    289
    Thanked 759 Times in 645 Posts
    Tests I tried last time now working fine - many thanks.

  23. The Following User Says Thank You to ccs For This Useful Post:

    bbbuk (28-06-20)

  24. #15

    Title
    Forum Supporter
    Donated Member
    Join Date
    Jun 2014
    Posts
    1,188
    Thanks
    526
    Thanked 387 Times in 245 Posts
    Quote Originally Posted by ccs View Post
    Tests I tried last time now working fine - many thanks.
    Created PR here for consideration/approval.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.