Results 1 to 7 of 7
  1. #1
    Junior Member

    Join Date
    May 2019
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Vix crashing when viewing 4:2:2 feed over network

    Hi all,

    Me and a friend both have an Octagon SF8008 and are running the latest OpenVix image. We have both experienced box crashes throughout the week when viewing a 4:2:2 feed over the network through VLC (via OpenWebif). I initially thought the first crash was due to both viewing the feed over VLC and recording to a HDD at the same time but this has since happened a further three times, when solely viewing the feed over the network using Openwebif.

    I have used the box for about 2 weeks and viewing normal broadcast channels is fine, it just doesn't seem to like 4:2:2 feeds. I don't know whether its the feed itself or the fact that I'm viewing it using OpenWebif > VLC, that is causing the box to hang. Me and my friend both get the spinning 'ViX' image in the left hand corner of the screen and the only way to overcome it is by toggling the power by the switch.

    The feed is opened with a valid BISS key and at first I suspected the crashes were linked to the softcam being used to read 'constant.cw'. However, the box crashed when I used both Oscam-EMU & NCam to read the constant.cw file. (both not running at the same time)

    I've attached my logs and a screenshot showing the plugins I have installed.

    Any help would be most appreciated as I've not had this happen on any other receiver/image.

    logs.zip
    1_0_1_320_3BC4_13E_820000_0_0_0_20190517232502.jpg
    Last edited by abu baniaz; 18-05-19 at 00:33. Reason: move request deleted as thread has been moved

  2. #2
    Senior Member

    Join Date
    Jul 2011
    Posts
    115
    Thanks
    72
    Thanked 41 Times in 26 Posts
    try this file. SatConfig.py (unzip)
    FTP /usr/lib/enigma2/python/Screens/

    restart enigma2...and test you feed 4:2:2
    Attached Files Attached Files

  3. The Following User Says Thank You to norhap For This Useful Post:

    abu baniaz (19-05-19)

  4. #3
    Junior Member

    Join Date
    May 2019
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by norhap View Post
    try this file. SatConfig.py (unzip)
    FTP /usr/lib/enigma2/python/Screens/

    restart enigma2...and test you feed 4:2:2

    Thank you

    I have just tried this file but noticed that in that folder, my SatConfig is named '.pyo' and not '.py'. I tried renaming the file you attached to '.pyo' and the box seems to reboot fine, but entering Tuner Config makes it crash. I have attached the crash log.
    Attached Files Attached Files

  5. #4
    ViX Beta Tester twol's Avatar

    Join Date
    Apr 2012
    Posts
    4,669
    Thanks
    594
    Thanked 1,503 Times in 1,173 Posts
    Don't rename it!!!
    Copy the .py to the directory and REBOOT... on reboot the .py will automatically be compiled and produce a .pyo that will replace the existing one!!
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    Edision Osmio 4K using Legacy ports on multiswitches
    Octagon SF8008 DVB-S2X tuner using Legacy ports on multiswitches
    Zgemma H9 using Legacy ports on multiswitches
    Zgemma H9Combo legacy ports on multiswitches
    Dinobot Mini 4K (C/S) into Giga 4K.

  6. The Following User Says Thank You to twol For This Useful Post:

    dankargo (19-05-19)

  7. #5
    Junior Member

    Join Date
    May 2019
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by twol View Post
    Don't rename it!!!
    Copy the .py to the directory and REBOOT... on reboot the .py will automatically be compiled and produce a .pyo that will replace the existing one!!
    Thank you! I have just done this again, simply using the '.py' file untouched and this has worked.

  8. #6
    Moderator abu baniaz's Avatar

    Join Date
    Sep 2010
    Location
    East London
    Posts
    18,630
    Thanks
    4,892
    Thanked 7,264 Times in 4,901 Posts
    Please delete the .py file, it hgas created the .pyo file now. We need to update the file, there is a bug affecting tuner setup. If you don't delete it, when you next update, you will be using the same file as you have now.

  9. #7
    Junior Member

    Join Date
    May 2019
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by abu baniaz View Post
    Please delete the .py file, it hgas created the .pyo file now. We need to update the file, there is a bug affecting tuner setup. If you don't delete it, when you next update, you will be using the same file as you have now.
    Thank you, I have deleted the '.py' file now. Just out of curiosity, is it this bug that was likely the cause of my crashes?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.