Hello Guest, if you are reading this it means you have not registered yet. Please take a second, Click here to register, and in a few simple steps you will be able to enjoy our community and use our OpenViX support section.
Page 28 of 33 FirstFirst ... 182627282930 ... LastLast
Results 406 to 420 of 483

Thread: Build my own Vix image

  1. #406
    Willo3092's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Oct 2016
    Location
    East Midlands
    Posts
    656
    Thanks
    583
    Thanked 272 Times in 201 Posts
    Quote Originally Posted by Huevos View Post
    Code:
    http://myvixbuild.xyz/feeds/openvix/release/5.5/sf8008/all
    What happen if you put that in a web browser?
    That isn't the actual url, I pm'd the correct one to Twol.
    I was just concerned about security on my server if I posted the correct url.

    If I paste the url followed by the plugin name.ipk it downloads via the browser okay.

  2. #407
    Huevos's Avatar
    Title
    Moderator
    Join Date
    Jun 2010
    Location
    38.5N, 0.5W
    Posts
    10,477
    Thanks
    1,806
    Thanked 3,852 Times in 2,536 Posts
    Also, from the debug log...
    Code:
    22:06:05.3185 [OnlineUpdateCheck][kernelMismatch] no kernel mismatch found
    Means it is accessing the feeds. If not it would say...
    Code:
    [OnlineUpdateCheck][kernelMismatch] error fetching http://myvixbuild.xyz/feeds/openvix/release/5.5/sf8008/sf8008/Packages.gz

  3. #408
    Willo3092's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Oct 2016
    Location
    East Midlands
    Posts
    656
    Thanks
    583
    Thanked 272 Times in 201 Posts
    If I go into the install plugins screen I just get a blank screen and pressing any button brings up the access denied symbol at top right.

    1_0_19_22D9_80D_2_11A0000_0_0_0_20210915095508.jpg

  4. #409
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    6,765
    Thanks
    847
    Thanked 2,391 Times in 1,830 Posts
    Quote Originally Posted by Willo3092 View Post
    If I go into the install plugins screen I just get a blank screen and pressing any button brings up the access denied symbol at top right.

    1_0_19_22D9_80D_2_11A0000_0_0_0_20210915095508.jpg
    So its hanging. I had this on my Synology(NAS) dns which worked fine in a browser but not from E2 (and I don't know why)
    Where are the feeds - on a HDD or NAS??
    If the feeds url is invalid it usually says so or returns blank screen .... but you can still access.
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  5. #410
    Willo3092's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Oct 2016
    Location
    East Midlands
    Posts
    656
    Thanks
    583
    Thanked 272 Times in 201 Posts
    Just tested downloading a skin via putty using the full path and it downloaded and installed okay:

    Code:
    opkg install http://myvixbuild/feeds/openvix/release/5.5/sf8008/sf8008/enigma2-plugin-skins-openvix-youvix-purple_5.5+git2786+331c423-r4_sf8008.ipk

  6. #411
    Willo3092's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Oct 2016
    Location
    East Midlands
    Posts
    656
    Thanks
    583
    Thanked 272 Times in 201 Posts
    Would it be because I built a release image perhaps? Does it need to be developer at this stage.
    I've tried the PluginBrowser.py from the dev build but that doesn't make any difference either.

  7. #412
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    6,765
    Thanks
    847
    Thanked 2,391 Times in 1,830 Posts
    Quote Originally Posted by Willo3092 View Post
    Would it be because I built a release image perhaps? Does it need to be developer at this stage.
    I've tried the PluginBrowser.py from the dev build but that doesn't make any difference either.
    No - shouldn‘t be any different……..but again Where are the feeds - on a HDD or NAS??
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  8. #413
    Willo3092's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Oct 2016
    Location
    East Midlands
    Posts
    656
    Thanks
    583
    Thanked 272 Times in 201 Posts
    They're on a NAS.

    I've now tried to use the feeds from the openvix-5.5.015.003.Py3-sf8008_mmc.zip and that doesn't work either although the About Boxbranding screen shows my server address so not sure if I need to change something there?

    I've also tried the PluginBrowser.py from that image as well.

    I've also built images for 2 different boxes and they are the same as well.

    I can download from my server through a browser and via putty using the same url as in the feeds and I've set the feeds up exactly the same as in ViX 5.4 which works perfectly.

    Running out of ideas now

  9. #414
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    6,765
    Thanks
    847
    Thanked 2,391 Times in 1,830 Posts
    Quote Originally Posted by Willo3092 View Post
    They're on a NAS.

    I've now tried to use the feeds from the openvix-5.5.015.003.Py3-sf8008_mmc.zip and that doesn't work either although the About Boxbranding screen shows my server address so not sure if I need to change something there?

    I've also tried the PluginBrowser.py from that image as well.

    I've also built images for 2 different boxes and they are the same as well.

    I can download from my server through a browser and via putty using the same url as in the feeds and I've set the feeds up exactly the same as in ViX 5.4 which works perfectly.

    Running out of ideas now
    Edit the conf files in /etc/opkg and put the real ip address(of the NAS) in rather than myvixbuild … makes sure that access is allowed from the sat receiver(nfs)
    You may be having the same issue that I had with my Synology NAS
    Last edited by twol; 15-09-21 at 19:00.
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  10. #415
    Willo3092's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Oct 2016
    Location
    East Midlands
    Posts
    656
    Thanks
    583
    Thanked 272 Times in 201 Posts
    Sorry, my bad. It's not a NAS it's on my website on hosting24.
    I can access plugin feeds on it from a ViX 5.4 build with no problems.

    Everything exactly the same apart from the feeds are in a 5.5 directory rather than 5.4.

  11. #416
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    6,765
    Thanks
    847
    Thanked 2,391 Times in 1,830 Posts
    @Willo3092 - You are going to hate this - installed your opkg feed conf's, and listed plugins no issues.
    Telnet to box, opkg update ............ downloads from your build url .... no issues
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  12. The Following User Says Thank You to twol For This Useful Post:

    Willo3092 (16-09-21)

  13. #417
    Willo3092's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Oct 2016
    Location
    East Midlands
    Posts
    656
    Thanks
    583
    Thanked 272 Times in 201 Posts
    Thanks twol, I really appreciate you taking the time to test. At least I know it's not my server or feeds now.
    Must be something wrong with the image I'm building then because I get the same on 3 different boxes.

    I set my build environment up using the guide for ATV 7.0, is it any different for ViX and is there a github page with a guide?

  14. #418
    Huevos's Avatar
    Title
    Moderator
    Join Date
    Jun 2010
    Location
    38.5N, 0.5W
    Posts
    10,477
    Thanks
    1,806
    Thanked 3,852 Times in 2,536 Posts
    Quote Originally Posted by Huevos View Post
    Also, from the debug log...
    Code:
    22:06:05.3185 [OnlineUpdateCheck][kernelMismatch] no kernel mismatch found
    Means it is accessing the feeds. If not it would say...
    Code:
    [OnlineUpdateCheck][kernelMismatch] error fetching http://myvixbuild.xyz/feeds/openvix/release/5.5/sf8008/sf8008/Packages.gz
    Have you looked at this. Would suggest something is wrong in PluginBrowser.

  15. #419
    twol's Avatar
    Title
    Moderator
    Join Date
    Apr 2012
    Posts
    6,765
    Thanks
    847
    Thanked 2,391 Times in 1,830 Posts
    Quote Originally Posted by Willo3092 View Post
    Thanks twol, I really appreciate you taking the time to test. At least I know it's not my server or feeds now.
    Must be something wrong with the image I'm building then because I get the same on 3 different boxes.

    I set my build environment up using the guide for ATV 7.0, is it any different for ViX and is there a github page with a guide?
    There is:
    https://github.com/OpenViX/enigma2/t...on3-compatible
    but its basically same as OpenATV.

    I still believe its a hang on the network.
    Download for instance Huevos py3 sf8008, flash a slot and then replace the /etc/opkg feed conf files with yours.... see if that works......... if you need another box then let me know and I will build it - at the moment I can still do it(my office will be empty shortly as we are having new floors and room has to be emptied).
    If it works its your build, which I find hard to believe - unless you are excluding some files from the build
    if it doesn't work then its your network access.
    Last edited by twol; 16-09-21 at 11:42.
    Gigablue Quad 4K & UE 4K
    .........FBC Tuners:
    ------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
    ------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
    .......................> FBC & DVB-S2X into 90cm dish (27.5W) Opticum robust Unicable LNB
    AX HD61, Edision Osmio 4K+, Zgemma H9Combo, Octagon SF8008 using Legacy ports on multiswitches
    Zgemma H9 C/S into Giga4K

  16. The Following User Says Thank You to twol For This Useful Post:

    Willo3092 (16-09-21)

  17. #420
    Willo3092's Avatar
    Title
    Forum Supporter
    Donated Member
    Join Date
    Oct 2016
    Location
    East Midlands
    Posts
    656
    Thanks
    583
    Thanked 272 Times in 201 Posts
    I copied my feeds to Huevos py3 build and all working fine
    As you say I will have to look at the image because I did exclude some stuff weeks ago when I kept getting build failures on a mips box.
    I'll try building again without the exclusions. Thanks twol

Page 28 of 33 FirstFirst ... 182627282930 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.