Results 1 to 10 of 10
  1. #1
    Junior Member

    Join Date
    Nov 2017
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Samba: problem copying files larger than 2GB

    Hi everyone,

    My first post here, so please accept my apologies if I forgot something. I have this weird issue where, whenever I try to copy a file from my VU+ Ultimo 4K to my Mac's hard drive, it fails after 4GB (I/O error) while files under 2GB copy perfectly.
    It also worked before when I was using a BlackHole image.

    So are there any parameters I should tweak/look for in the samba configuration files to fix this ?

    Thank you already !


    Daniel
    Last edited by timberland; 10-10-18 at 12:56.

  2. #2
    ViX Beta Tester birdman's Avatar

    Join Date
    Sep 2014
    Location
    Hitchin, UK
    Posts
    5,376
    Thanks
    130
    Thanked 1,149 Times in 916 Posts
    Quote Originally Posted by timberland View Post
    Hi everyone,

    My first post here, so please accept my apologies if I forgot something. I have this weird issue where, whenever I try to copy a file from my VU+ Ultimo 4K to my Mac's hard drive, it fails after 4GB (I/O error) while files under 2GB copy perfectly.
    It also worked before when I was using a BlackHole image.

    So are there any parameters I should tweak/look for in the samba configuration files to fix this ?
    If the actual file-system is on the Mac you're not using Samba (a server process) on the Vix box - you'll be using the cifs kernel module.

    It might be that there are options on the Mac to allow 64-bit file-sizes?
    MiracleBox Prem Twin HD - 2@DVB-T2 + Xtrend et8000 - 5(incl. 2 different USBs)@DVB-T2[terrestrial - UK Freeview HD, Sandy Heath] - LAN/USB-stick/HDD

  3. #3
    Moderator abu baniaz's Avatar

    Join Date
    Sep 2010
    Location
    East London
    Posts
    19,507
    Thanks
    5,050
    Thanked 7,695 Times in 5,162 Posts
    We also have the AFS modules, that may be better suited for the OP

  4. #4
    Junior Member

    Join Date
    Nov 2017
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you both for your replies. I can copy larger files from othe SMB servers and it only started happening after I changed from BlackHole to OpenVIX, so there must be a difference. The Mac hasn't changed.

    As for AFP, I tried installing it from the Network->Utilities menu but it only says it will restart the box and it does, but after that it is not installed and I can install it again but with the same result.

    I'll keep digging !

    Thanks again !

    Daniel

  5. #5
    Junior Member

    Join Date
    Nov 2011
    Posts
    4
    Thanks
    15
    Thanked 0 Times in 0 Posts
    Same problem on vu+ solo2 with latest openvix. Can't copy files lager than 2gb and afp can't be installed. Tried install open-vpn but after install it can't be started.
    Returned to 5.1 version, that one worked before the update to latest openvix, but now it doesn't anymore.
    Haven't tried update without restore yet.

    Tia.
    Last edited by palantir; 22-12-18 at 18:32.

  6. #6
    Junior Member

    Join Date
    Nov 2017
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The only solution I found was to use FTP but it is not very convenient...

  7. #7
    Junior Member

    Join Date
    Nov 2011
    Posts
    4
    Thanks
    15
    Thanked 0 Times in 0 Posts
    I'll try that. If that works, it's better than nothing.
    Thanks.

  8. #8
    Junior Member

    Join Date
    Nov 2017
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    You're welcome ! P.S. I use Transmit on the Mac for that.

    Daniel

  9. #9
    Junior Member

    Join Date
    Apr 2012
    Posts
    4
    Thanks
    0
    Thanked 3 Times in 3 Posts
    My problem was the other way round. Couldn't upload more than 2GB to the box. "Transmit" was also the solution for me

  10. #10
    ViX Beta Tester birdman's Avatar

    Join Date
    Sep 2014
    Location
    Hitchin, UK
    Posts
    5,376
    Thanks
    130
    Thanked 1,149 Times in 916 Posts
    No idea whether this is related, but...

    Code:
     https://github.com/oe-alliance/oe-alliance-core/commit/0ebae8cad82312410b69ca8f3472831747c76fdd
    The comment says, "Also fix 2 GB limit due to previously broken waf-answer-files".
    MiracleBox Prem Twin HD - 2@DVB-T2 + Xtrend et8000 - 5(incl. 2 different USBs)@DVB-T2[terrestrial - UK Freeview HD, Sandy Heath] - LAN/USB-stick/HDD

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.